summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorToby Vincent <tobyv13@gmail.com>2023-04-28 17:32:24 -0500
committerToby Vincent <tobyv13@gmail.com>2023-04-28 17:32:24 -0500
commit589cd987217755e1da7acbc304c373a75a9f7db5 (patch)
tree2730a697e4f7b2f779fcd96b0452719cc67f36e3 /Cargo.toml
parenta98b50667bc6a11e4b8be464969adc14601e9e78 (diff)
refactor: simplify logic and clean up dep.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 2 insertions, 11 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ae19f83..6aa170d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,8 +2,9 @@
name = "projectr"
version = "0.2.1"
edition = "2021"
+description = "Outputs a MRU sorted list subdirectories matching specified criteria."
authors = ["Toby Vincent <tobyv13@gmail.com>"]
-homepage = "https://sr.ht/~tobyvin/tmuxr"
+homepage = "https://git.sr.ht/~tobyvin/projectr"
repository = "https://git.sr.ht/~tobyvin/projectr"
license = "MIT"
@@ -12,23 +13,13 @@ license = "MIT"
[dependencies]
anyhow = "1.0.66"
clap = { version = "4.0.18", features = ["derive", "env"] }
-figment = { version = "0.10.8", features = ["toml", "env", "test"] }
git2 = { version = "0.15.0", default-features = false, optional = true, features = [
"vendored-libgit2",
] }
ignore = "0.4.18"
-pretty_assertions = "1.3.0"
-serde = { version = "1.0.147", features = ["derive"] }
-serde_with = "2.1.0"
-thiserror = "1.0.37"
-tokio = { version = "1.23.0", features = ["full"] }
tracing = { version = "0.1.37", features = ["attributes"] }
tracing-subscriber = { version = "0.3.16", features = ["env-filter"] }
-[dev-dependencies]
-tempfile = "3.3.0"
-toml = "0.5.9"
-
[features]
default = ["git"]
git = ["dep:git2"]