summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorToby Vincent <tobyv13@gmail.com>2023-04-05 13:04:41 -0500
committerToby Vincent <tobyv13@gmail.com>2023-04-05 13:04:41 -0500
commitb64c56a782647de4da39617e8d047796da242ddc (patch)
tree1d6534c3b021ed50f6c9f8f8ec79221752f9a3fa /Cargo.toml
parent19ccec311d29e7426645b5ade9f0f1cbb4a75579 (diff)
fix: use vendered libgit2 to avoid shared dependency issues
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d102c77..987c876 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,7 +13,9 @@ license = "MIT"
anyhow = "1.0.66"
clap = { version = "4.0.18", features = ["derive", "env"] }
figment = { version = "0.10.8", features = ["toml", "env", "test"] }
-git2 = { version = "0.15.0", default-features = false, optional = true }
+git2 = { version = "0.15.0", default-features = false, optional = true, features = [
+ "vendored-libgit2",
+] }
ignore = "0.4.18"
pretty_assertions = "1.3.0"
serde = { version = "1.0.147", features = ["derive"] }