summaryrefslogtreecommitdiffstats
path: root/xtask/Cargo.toml
diff options
context:
space:
mode:
authorToby Vincent <tobyv13@gmail.com>2023-06-03 21:34:21 -0500
committerToby Vincent <tobyv13@gmail.com>2023-06-03 21:34:21 -0500
commitc6e8c15b39781ce48cd3f0d829ab5c6574ccd01b (patch)
treefa8966f5d2058a349bd0b9b5dd5b0cf9854bbb39 /xtask/Cargo.toml
parente5dd5a260c48ee7f2d22e75433e463eb092ec698 (diff)
build: add xtask release command
Diffstat (limited to 'xtask/Cargo.toml')
-rw-r--r--xtask/Cargo.toml10
1 files changed, 10 insertions, 0 deletions
diff --git a/xtask/Cargo.toml b/xtask/Cargo.toml
index 5040f0a..1694407 100644
--- a/xtask/Cargo.toml
+++ b/xtask/Cargo.toml
@@ -13,3 +13,13 @@ anyhow = { workspace = true }
clap = { workspace = true }
tar = "0.4.38"
flate2 = "1.0.26"
+semver = "1.0.17"
+toml_edit = { version = "0.19.10", features = ["serde"] }
+
+[dependencies.chrono]
+version = "0.4.26"
+default-features = false
+features = ["std", "clock"]
+
+[dev-dependencies]
+similar-asserts = "1.4.2"