summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorToby Vincent <tobyv@tobyvin.dev>2024-09-26 17:31:16 -0500
committerToby Vincent <tobyv@tobyvin.dev>2024-09-26 17:31:16 -0500
commitfd992d7e3c03f37fbcafe9d3f26c72a2ead3b2a7 (patch)
treef3e29427d1bbe4a8d6e050abbd9f66afb5fa2152 /Cargo.toml
parentcbfca14b38806798847e3f2008038b25194a9b8b (diff)
feat!: impl full api
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 10 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0a558a2..69f7eeb 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -4,8 +4,18 @@ version = "0.1.0"
edition = "2021"
[dependencies]
+axum = "0.7.6"
+axum-extra = "0.9.4"
+futures = "0.3.30"
+futures-util = "0.3.30"
+hyper-util = { version = "0.1.9", features = ["tokio"] }
main_error = "0.1.2"
reqwest = { version = "0.12.7", features = ["blocking"] }
serde = { version = "1.0.210", features = ["derive"] }
+serde_json = "1.0.128"
thiserror = "1.0.63"
+tokio = { version = "1.40.0", features = ["macros", "rt-multi-thread", "net"] }
toml = "0.8.19"
+tower-http = { version = "0.6.1", features = ["fs", "trace"] }
+tracing = "0.1.40"
+tracing-subscriber = { version = "0.3.18", features = ["env-filter"] }