summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorToby Vincent <tobyv@tobyvin.dev>2024-10-01 13:15:24 -0500
committerToby Vincent <tobyv@tobyvin.dev>2024-10-01 13:15:24 -0500
commitfe16a923190243dfde5db6ceff2ef0bcf9158926 (patch)
tree9b8b616e1972ca3ef6e28d29c980899af3ddde49 /Cargo.toml
parente1d9c956beb6921b0d549248bea3a6853fde5f46 (diff)
feat: simplify service status type
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 7 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1cb7655..b70af54 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,11 +11,16 @@ futures = "0.3.30"
futures-util = "0.3.30"
hyper-util = { version = "0.1.9", features = ["tokio"] }
main_error = "0.1.2"
-reqwest = { version = "0.12.7", features = ["blocking"] }
+reqwest = "0.12.7"
serde = { version = "1.0.210", features = ["derive"] }
serde_json = "1.0.128"
thiserror = "1.0.63"
-tokio = { version = "1.40.0", features = ["macros", "rt-multi-thread", "net", "time"] }
+tokio = { version = "1.40.0", features = [
+ "macros",
+ "rt-multi-thread",
+ "net",
+ "time",
+] }
tokio-stream = { version = "0.1.16", features = ["sync"] }
toml = "0.8.19"
tower-http = { version = "0.6.1", features = ["fs", "trace"] }