summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml11
1 files changed, 10 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f0106a8..ff7fccc 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,6 +2,9 @@
name = "statsrv"
version = "0.1.0"
edition = "2021"
+license = "MIT"
+authors = ["Toby Vincent <tobyv@tobyvin.dev>"]
+description = "Minimal and flexable service status API"
[dependencies]
async-stream = "0.3.5"
@@ -13,7 +16,13 @@ reqwest = "0.12.7"
serde = { version = "1.0.210", features = ["derive"] }
serde_json = "1.0.128"
thiserror = "1.0.63"
-tokio = { version = "1.40.0", features = ["macros", "rt-multi-thread", "net", "time", "process"] }
+tokio = { version = "1.40.0", features = [
+ "macros",
+ "rt-multi-thread",
+ "net",
+ "time",
+ "process",
+] }
tokio-stream = { version = "0.1.16", features = ["io-util", "sync"] }
toml = "0.8.19"
tower-http = { version = "0.6.1", features = ["fs", "trace"] }