summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 1 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ff7fccc..5dba372 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,11 +7,8 @@ authors = ["Toby Vincent <tobyv@tobyvin.dev>"]
description = "Minimal and flexable service status API"
[dependencies]
-async-stream = "0.3.5"
axum = "0.7.6"
futures = "0.3.30"
-futures-util = "0.3.30"
-hyper-util = { version = "0.1.9", features = ["tokio"] }
reqwest = "0.12.7"
serde = { version = "1.0.210", features = ["derive"] }
serde_json = "1.0.128"
@@ -23,12 +20,9 @@ tokio = { version = "1.40.0", features = [
"time",
"process",
] }
-tokio-stream = { version = "0.1.16", features = ["io-util", "sync"] }
+tokio-util = "0.7.12"
toml = "0.8.19"
tower-http = { version = "0.6.1", features = ["fs", "trace"] }
tracing = "0.1.40"
tracing-subscriber = { version = "0.3.18", features = ["env-filter"] }
url = { version = "2.5.2", features = ["serde"] }
-
-[dev-dependencies]
-tracing-test = "0.2.5"