summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorToby Vincent <tobyv@tobyvin.dev>2024-04-02 17:23:05 -0500
committerToby Vincent <tobyv@tobyvin.dev>2024-04-02 17:32:38 -0500
commitd3a09372b5b945a609cce5e28c4d4233e3b134e8 (patch)
tree9f888aa393948e1c90d76d37349ffe9738b95f24 /Cargo.toml
parentb263c6637ce8b7c83e4d01d1ef2e90e195a155fb (diff)
feat: impl toml file and env config layering
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1ae7a29..430f228 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,12 +12,14 @@ axum-extra = { version = "0.9.3", features = ["typed-routing", "cookie", "typed-
dotenvy = "0.15.7"
email_address = "0.2.4"
jsonwebtoken = "9.3.0"
+main_error = "0.1.2"
serde = { version = "1.0.197", features = ["derive"] }
serde_json = "1.0.114"
sqlx = { version = "0.7.3", features = ["postgres", "runtime-tokio", "uuid", "time"] }
thiserror = "1.0.58"
time = { version = "0.3.34", features = ["serde", "serde-human-readable"] }
tokio = { version = "1.36.0", features = ["macros", "rt-multi-thread", "signal"] }
+toml = "0.8.12"
tracing = "0.1.40"
tracing-subscriber = { version = "0.3.18", features = ["env-filter"] }
uuid = { version = "1.8.0", features = ["serde"] }