summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorToby Vincent <tobyv@tobyvin.dev>2024-03-20 14:22:24 -0500
committerToby Vincent <tobyv@tobyvin.dev>2024-03-20 19:21:29 -0500
commitf977dce01be9de61a64b94aab883fb43949234b3 (patch)
treee8b3b5b59b10d43619198ff7d0f9f0e10bed0818 /Cargo.toml
chore: initial commit
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..874d5ab
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "unnamed-server"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+anyhow = "1.0.81"
+axum = "0.7.4"
+axum-extra = { version = "0.9.2", features = ["typed-routing"] }
+serde_json = "1.0.114"
+thiserror = "1.0.58"
+tokio = { version = "1.36.0", features = ["macros", "rt-multi-thread", "signal"] }
+tracing = "0.1.40"
+tracing-subscriber = { version = "0.3.18", features = ["env-filter"] }