summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 975ef91..1ae7a29 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,14 +8,15 @@ edition = "2021"
[dependencies]
argon2 = { version = "0.5.3", features = ["std"] }
axum = "0.7.4"
-axum-extra = { version = "0.9.2", features = ["typed-routing"] }
+axum-extra = { version = "0.9.3", features = ["typed-routing", "cookie", "typed-header"] }
dotenvy = "0.15.7"
email_address = "0.2.4"
+jsonwebtoken = "9.3.0"
serde = { version = "1.0.197", features = ["derive"] }
serde_json = "1.0.114"
sqlx = { version = "0.7.3", features = ["postgres", "runtime-tokio", "uuid", "time"] }
thiserror = "1.0.58"
-time = { version = "0.3.34", features = ["serde"] }
+time = { version = "0.3.34", features = ["serde", "serde-human-readable"] }
tokio = { version = "1.36.0", features = ["macros", "rt-multi-thread", "signal"] }
tracing = "0.1.40"
tracing-subscriber = { version = "0.3.18", features = ["env-filter"] }