aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorToby Vincent <tobyv13@gmail.com>2023-01-11 19:07:22 -0600
committerToby Vincent <tobyv13@gmail.com>2023-01-11 19:07:22 -0600
commitf96e6f042fa8ab0e61e7c10739eafd1155a32eff (patch)
treea10c41ed08cdf54c3226149605eb962c2bf3202c /Cargo.toml
parent14b367de207df7cb57bb54512b8963ef7d3221fa (diff)
revert(preview)!: remove preview feat and unused deps
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml18
1 files changed, 2 insertions, 16 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 376cab3..d102c77 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,27 +12,14 @@ license = "MIT"
[dependencies]
anyhow = "1.0.66"
clap = { version = "4.0.18", features = ["derive", "env"] }
-dirs = "4.0.0"
figment = { version = "0.10.8", features = ["toml", "env", "test"] }
git2 = { version = "0.15.0", default-features = false, optional = true }
ignore = "0.4.18"
-onefetch = { version = "2.14.2", optional = true }
pretty_assertions = "1.3.0"
serde = { version = "1.0.147", features = ["derive"] }
serde_with = "2.1.0"
-sled = "0.34.7"
-ssh_cfg = { version = "0.3.0", optional = true }
thiserror = "1.0.37"
-tmux_interface = { version = "0.2.1", default-features = false, features = [
- "tmux_latest",
-] }
-tokio = { version = "1.23.0", features = [
- "signal",
- "tracing",
- "macros",
- "rt-multi-thread",
- "full",
-] }
+tokio = { version = "1.23.0", features = ["full"] }
tracing = { version = "0.1.37", features = ["attributes"] }
tracing-subscriber = { version = "0.3.16", features = ["env-filter"] }
@@ -41,6 +28,5 @@ tempfile = "3.3.0"
toml = "0.5.9"
[features]
-default = ["git", "preview"]
+default = ["git"]
git = ["dep:git2"]
-preview = ["dep:onefetch"]