aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 8 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9d94e01..1e6de2e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -24,6 +24,12 @@ tracing-subscriber = { version = "0.3.16", features = ["env-filter"] }
default = ["git"]
git = ["dep:git2"]
+[package.metadata.release]
+allow-branch = ["main", "!HEAD"]
+sign-commit = true
+sign-tag = true
+tag-message = "{{crate_name}} version {{version}}"
+
[[package.metadata.release.pre-release-replacements]]
file = "CHANGELOG.md"
search = '''(## \[Unreleased\])'''
@@ -44,5 +50,5 @@ exactly = 1
[[package.metadata.release.pre-release-replacements]]
file = "README.md"
-search = '''(https://git.sr.ht/~tobyvin/projectr/tree/v)\d+\.\d+\.\d+(/item)'''
-replace = "$1{{version}}$2"
+search = '''https://git.sr.ht/~tobyvin/projectr/tree/v\d+\.\d+\.\d+/item'''
+replace = "https://git.sr.ht/~tobyvin/projectr/tree/v{{version}}/item"