aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 7 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 422dc61..f77632f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,9 +14,9 @@ anyhow = "1.0.66"
clap = { version = "4.0.18", features = ["derive", "env"] }
dirs = "4.0.0"
figment = { version = "0.10.8", features = ["toml", "env", "test"] }
-git2 = { version = "0.15.0", default-features = false }
+git2 = { version = "0.15.0", default-features = false, optional = true }
ignore = "0.4.18"
-onefetch = "2.14.2"
+onefetch = { version = "2.14.2", optional = true }
pretty_assertions = "1.3.0"
serde = { version = "1.0.147", features = ["derive"] }
sled = "0.34.7"
@@ -30,3 +30,8 @@ tracing-subscriber = { version = "0.3.16", features = ["env-filter"] }
[dev-dependencies]
tempfile = "3.3.0"
+
+[features]
+default = ["git", "preview"]
+git = ["dep:git2"]
+preview = ["dep:onefetch"]