summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml28
1 files changed, 28 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..175f194
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,28 @@
+[package]
+name = "twitch-live"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+futures = "0.3.30"
+main_error = "0.1.2"
+reqwest = "0.12.4"
+rpassword = "7.3.1"
+serde = { version = "1.0.200", features = ["derive"] }
+tokio = { version = "1.37.0", features = ["macros", "rt-multi-thread"] }
+toml = "0.8.12"
+tracing = "0.1.40"
+tracing-subscriber = { version = "0.3.18", features = ["env-filter"] }
+# twitch_api = { version = "0.7.0-rc.7", features = ["client", "helix", "reqwest"] }
+# twitch_oauth2 = { version = "0.13.0", features = ["client", "reqwest"] }
+twitch_api = { git = "https://github.com/twitch-rs/twitch_api/", features = ["client", "helix", "reqwest"] }
+twitch_oauth2 = { git = "https://github.com/twitch-rs/twitch_api/", features = ["client", "reqwest"] }
+twitch_types = { git = "https://github.com/twitch-rs/twitch_api/" }
+
+# workaround for https://github.com/twitch-rs/twitch_api/issues/256
+[patch.crates-io.twitch_types]
+git = "https://github.com/twitch-rs/twitch_api"
+[patch.crates-io.twitch_oauth2]
+git = "https://github.com/twitch-rs/twitch_api"