summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorToby Vincent <tobyv@tobyvin.dev>2024-04-06 21:29:15 -0500
committerToby Vincent <tobyv@tobyvin.dev>2024-04-06 21:29:15 -0500
commit9a6c04d52edb10431f9f5ca2dbc83c410cb5daee (patch)
treeab6771edec6accbbe6e20a0cb0124390a372d576 /Cargo.toml
parent9822bc18bb0cb5e13104376ecefc6ec99d93b016 (diff)
fix: enable permissive cors middleware
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 430f228..4031058 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -20,9 +20,10 @@ thiserror = "1.0.58"
time = { version = "0.3.34", features = ["serde", "serde-human-readable"] }
tokio = { version = "1.36.0", features = ["macros", "rt-multi-thread", "signal"] }
toml = "0.8.12"
+tower-http = { version = "0.5.2", features = ["cors"] }
tracing = "0.1.40"
tracing-subscriber = { version = "0.3.18", features = ["env-filter"] }
-uuid = { version = "1.8.0", features = ["serde"] }
+uuid = { version = "1.8.0", features = ["serde", "v4"] }
[dev-dependencies]
pgtemp = "0.2.1"