summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorToby Vincent <tobyv@tobyvin.dev>2024-03-26 21:04:02 -0500
committerToby Vincent <tobyv@tobyvin.dev>2024-03-26 21:04:02 -0500
commitce961ca85ba96813ccdca9be1d18ee11e4e0d25c (patch)
tree4e368e35c275ea1be97473ae69aa052f4a0e98a2 /Cargo.toml
parentfd1447999d9665866d65002b2c2317b8b150225f (diff)
feat: add user database and registration
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml14
1 files changed, 9 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a7ace5d..fd2b28e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -6,18 +6,22 @@ edition = "2021"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-anyhow = "1.0.81"
-argon2 = "0.5.3"
+argon2 = { version = "0.5.3", features = ["std"] }
axum = "0.7.4"
axum-extra = { version = "0.9.2", features = ["typed-routing"] }
-axum-test = "14.4.0"
-chrono = { version = "0.4.35", features = ["serde"] }
dotenvy = "0.15.7"
serde = { version = "1.0.197", features = ["derive"] }
serde_json = "1.0.114"
-sqlx = { version = "0.7.3", features = ["postgres", "runtime-tokio", "uuid", "chrono"] }
+sqlx = { version = "0.7.3", features = ["postgres", "runtime-tokio", "uuid", "time"] }
thiserror = "1.0.58"
+time = { version = "0.3.34", features = ["serde"] }
tokio = { version = "1.36.0", features = ["macros", "rt-multi-thread", "signal"] }
tracing = "0.1.40"
tracing-subscriber = { version = "0.3.18", features = ["env-filter"] }
uuid = { version = "1.8.0", features = ["serde"] }
+
+[dev-dependencies]
+pgtemp = "0.2.1"
+tower = { version = "0.4.13", features = ["util"] }
+mime = "0.3.17"
+http-body-util = "0.1.1"