aboutsummaryrefslogtreecommitdiffstats
path: root/zone_core/Cargo.toml
diff options
context:
space:
mode:
authorToby Vincent <tobyv13@gmail.com>2022-03-17 18:19:50 -0500
committerToby Vincent <tobyv13@gmail.com>2022-03-17 18:19:50 -0500
commite18482558a43330cab726ae92518904be346a248 (patch)
tree0ec733e16c2511734a155b5d59c6bd5ddba00aa1 /zone_core/Cargo.toml
parent8858295736b507825f279f51303ab6e9f939f423 (diff)
refactor: migrated from rocket to axum
Diffstat (limited to 'zone_core/Cargo.toml')
-rw-r--r--zone_core/Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/zone_core/Cargo.toml b/zone_core/Cargo.toml
index bd2a8f4..6dffa1a 100644
--- a/zone_core/Cargo.toml
+++ b/zone_core/Cargo.toml
@@ -13,8 +13,6 @@ description = "Manages containers using systemd-nspawn and ZFS"
[dependencies]
clap = { version = "3.0.13", default-features = false, features = ["std", "derive"] }
-rocket = { version = "0.5.0-rc.1", default-features = false, features = ["json"] }
-rocket_okapi = { version = "0.8.0-rc.1" }
serde = "1.0.136"
strum = "0.23.0"
strum_macros = "0.23.1"
@@ -22,3 +20,6 @@ tabled = "0.4.2"
zone_zfs = { version = "0.1.0", path = "../zone_zfs" }
zone_nspawn = { version = "0.1.0", path = "../zone_nspawn" }
thiserror = "1.0.30"
+derive_builder = "0.10.2"
+
+[features]