aboutsummaryrefslogtreecommitdiffstats
path: root/zoned/Cargo.toml
diff options
context:
space:
mode:
authorToby Vincent <tobyv13@gmail.com>2022-02-13 21:14:33 -0600
committerToby Vincent <tobyv13@gmail.com>2022-02-13 21:14:33 -0600
commit8985b2ffd7c8d6e9cf726f630f39ce6e8f00df79 (patch)
tree3e632e691378e36d389393d80049fa81c1b8f9cf /zoned/Cargo.toml
parent96e571eca2991a19fc9bcdc26e451c4fad5bc791 (diff)
refactor: add error handling to libraries
refactor libraries from using anyhow to explicitly handling errors
Diffstat (limited to 'zoned/Cargo.toml')
-rw-r--r--zoned/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/zoned/Cargo.toml b/zoned/Cargo.toml
index 4983d03..28d1650 100644
--- a/zoned/Cargo.toml
+++ b/zoned/Cargo.toml
@@ -12,11 +12,13 @@ description = "daemon for managing containers using systemd-nspawn and ZFS"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
+anyhow = "1.0.53"
figment = "0.10.6"
lazy_static = "1.4.0"
rocket = { version = "0.5.0-rc.1", default-features = false, features = ["json"] }
rocket_okapi = { version = "0.8.0-rc.1", features = ["rapidoc", "swagger"] }
serde = "1.0.136"
+thiserror = "1.0.30"
zone_core = { version = "0.1.0", path = "../zone_core" }
zone_nspawn = { version = "0.1.0", path = "../zone_nspawn" }
zone_zfs = { version = "0.1.0", path = "../zone_zfs" }