aboutsummaryrefslogtreecommitdiffstats
path: root/zone_core/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'zone_core/Cargo.toml')
-rw-r--r--zone_core/Cargo.toml25
1 files changed, 13 insertions, 12 deletions
diff --git a/zone_core/Cargo.toml b/zone_core/Cargo.toml
index 0f79478..5255f3a 100644
--- a/zone_core/Cargo.toml
+++ b/zone_core/Cargo.toml
@@ -1,19 +1,22 @@
[package]
name = "zone_core"
-version = "0.1.0"
-edition = "2021"
-license = "MIT"
-authors = [
- "Neil Kollack <nkollack@gmail.com>",
- "Toby Vincent <tobyv13@gmail.com>",
-]
-description = "Core types and traits for zone"
-keywords = ["zone", "zoned"]
+version.workspace = true
+authors.workspace = true
+edition.workspace = true
+description.workspace = true
+homepage.workspace = true
+repository.workspace = true
+license.workspace = true
+keywords.workspace = true
+categories.workspace = true
workspace = ".."
[dependencies]
async-trait = "0.1.57"
-clap = { version = "3.2.22", default-features = false, features = ["std", "derive"] }
+clap = { version = "3.2.22", default-features = false, features = [
+ "std",
+ "derive",
+] }
derive_builder = "0.11.2"
serde = "1.0.145"
strum = "0.24.1"
@@ -22,5 +25,3 @@ tabled = "0.8.0"
thiserror = "1.0.36"
tokio = "1.21.1"
wspty = "0.1.1"
-
-[features]